Framework YII, tidak memerlukan installasi. Cukup download framework dari yiiframework.com dan letakkan di htdocs atau www dari webserver.

Yang harus dilakukan :

WINDOWS,Setting path ke php folder. Misal di WAMP adalah c:/wamp/php

LINUX, Install PHP Command Line dengan sudo apt-get install php5-cli

Pastikan Requirement terpenuhi (http://localhost/yii/requirements/)

  1. PHP 5.1.0 or higher is required.
  2. Extension yang diperlukan :
    • php_pdo_mysql.dll (PDO MySQL extension)
    • php_soap.dll (SOAP extension)
    • php_mycrypt.dll (Mcrypt extension)
    • php_memcache.dll (Memcache extension )

Sumber : yiiframework.com